如果没必要,不要太折腾

2021-04-13
评论
1

从阿里云服务器的开始,换了节点地域,然后重新购买配置。安装AMH主机面板,恢复环境,数据,然后升级PHP版本到PHP8.0,升级Nginx到1.18,升级数据库到Mysql8.0。升级数据库到Mysql8.0真的是费劲儿。需要大内存!!!

如果没必要,不要太折腾

而后出现Begin主题对php8.0的支持还不够完善,的确是因为目前升级到php8.0有些激进。

此次升级出现了三个问题:

一个是Begin主题携带插件的“大家喜欢”小工具出现数据库错误,这一问题“错误”在php7.3测试没有发生。主题不兼容或者Wordpress程序不兼容。

二个是友情链接提交申请的错误提示,这里应该是Begin主题不兼容导致的报错,因为php7.3同样。提交友链申请后提示错误但是提交是成功的。提示:不建议的数据库语句。

三个是Wordpress的OSS Upload插件可能不兼容php8.0,导致无法上传图片到阿里云oss。暂时找到OSS Aliyun插件使用,希望XiaoMac还会更新插件。并感谢OSS Aliyun的作者“沈唁”的帮助。

目前错误不耽误使用,暂且用吧,人生本来一切都是暂时的而已!

  • 我的微信
  • 这是我的微信扫一扫
  • weinxin
  • 微信公众号
  • 艾因微信公众号
  • weinxin
  • 本文由 发表于 2021-04-13
  • 内容信息及资源引用、摘录或转载自网络,由弦夕收藏整理,旨在提供阅览实用性之参考!对文章中的观点均保持中立,仅供交流之目的。默认遵循各个平台原创转载规则,若来源标注错误或侵犯到您的权益,烦请与之联系,即刻处理。
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: